【初心者向け】 簡単BGP講座 11.NATを併用してみよう


■基礎編
 1.はじめに
 2.構成説明
 3.基本Configを入れてみよう
 4.ステータスを確認しよう

■アレンジ編
 5.as-pathfilterを入れよう
 6.prefix-listを使おう
 7.Configをグループ化
 8.LocalPreference値で経路制御してみよう
 9.VRRP Trackingを組み合わせよう
 10.MED値でお願いしてみよう
 11.NATを併用してみよう

■再配送
 12.Staticを再配布しよう
 13.BGPをOSPFに再配布しよう
 14.OSPFをBGPに再配布しよう

#####################################################

■構成図

GW-20140105-055201

■はじめに

BGPにかぎらず外部接続をする際に切っても切れないのがNATです。
NATとルーティングとACLを全部Cisco1台でやる時は頭が慣れるまで苦戦するかもしれません。

NAT の処理順序

Ciscoは処理順番を公開しているのですが、他のメーカーの機器は
その手の情報がなかったりして苦労したりします。

外部サイトとの接続の場合、たいてい向こうが

と言ってくるで仕方なく引き受けましょう。
NATはルータにとって負荷のかかる機能なので、大きなネットワークだと
NATをするためだけのルータを配置したりします。
(以前某アメリカ製L3SWでNATやった時は泣いたな)

NATが絡む案件ではこんな図を作って手元に置いておきます。

GW-20140105-140910

ネットワークの区間毎にパケットのどういう状態になっているか、の早見図です。
これが規模が大きいネットワークでもパッと頭に描けるなら初心者卒業といえるでしょう。
今回のテストではBGPでルーティングしつつ、ソースNATを下記の要件で実装します。

■要件

 10.111.222.32/28を先方指定のNAT範囲とする。
 今回はDynamic NATを使う。

 NAT前 192.168.200.33-46
  ↓
 NAT後 10.111.222.33-46

このNAT要件を今まで作ったConfigに実装してみます。

■実装

ルータA,B
router bgp 30000
network 10.111.222.32 mask 255.255.255.240
→NATセグメントを配信

ip prefix-list AS20000-haihu-list seq 20 permit 10.111.222.32/28
→AS20000の配信セグメントに追加

interface FastEthernet0
ip nat outside
interface Vlan200
ip nat inside

access-list 10 permit 192.168.200.32 0.0.0.15
ip nat pool AS20000-nat 10.111.222.33 10.111.222.46 netmask 255.255.255.240
ip nat inside source list 10 pool AS20000-nat
→NATの定義

ip route 10.111.222.32 255.255.255.240 Vlan200
→outsideからinsideへの戻り通信の際、CiscoではNAT処理が先に
 来るため、本設定は無意味だが、ベンダーによってもしルーティング処理が
 先になる場合、NATセグメントは本機に存在しているよ!と明示する。

■疎通確認

2621XM-C#
2621XM-C#debug ip icmp
ICMP packet debugging is on
2621XM-C#
2621XM-C#
*Jan 13 15:28:07.869: ICMP: echo reply sent, src 172.16.100.1, dst 10.111.222.33
*Jan 13 15:28:08.869: ICMP: echo reply sent, src 172.16.100.1, dst 10.111.222.33
*Jan 13 15:28:09.877: ICMP: echo reply sent, src 172.16.100.1, dst 10.111.222.33
*Jan 13 15:28:10.877: ICMP: echo reply sent, src 172.16.100.1, dst 10.111.222.33
2621XM-C#
2621XM-C#

host1からルータCの内部アドレスへPing。
正常にNAT後IPが見え、パケットを返している。

■Config

part11.ルータA_config

part11.ルータB_config

※両機でOS Verが違うため、一部投入してるのに非表示になるConfigがあります。
 ルータA・・15.1
 ルータB・・12.4

BGPとNATが使いこなせれば、かなりのものです。
ここで紹介してるのはBGPでも一部ですが、知ってる部分をきっかけに
じわじわと知識を広げていけばいいのだと思います。

そして最後は、いよいよラスト、再配送です。

Leave a comment

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください